Child pages
  • The Servoy Design Perspective

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Table of Contents

Info

Note: When you open the Servoy Developer opens (after closing the Welcome window), you will see an iServoy view the StartPage is shown in the Editor area. This view page shows links to online Servoy resources and headlines, including the online forum, blog, new releases, and events. When you close closing and reopen reopening Servoy, the perspective will load with the last set of editors that were active or loaded before closing.

The Solution Explorer

The Solution Explorer view is a hierarchal hierarchical tree view of all the objects available in Servoy Developer. It is central to the Servoy development environment; everything you that one can do in Developer can be found in the Solution Explorer.

The Solution Explorer has two parts, the tree of objects (appears on top) and a contextual list (appears below). Depending on what is selected in the tree view, different objects will appear in the list view.

The following nodes in the Solution Explorer are of note:

  • Resources – Within the Resources project are the list of database servers, styles, security options, i18n files, and templates available to the user within the current workspace.
  • All solutions – Lists the Servoy project solutions in the current workspace. A solution can be activated from this list for development by right-clicking on the solution name and selecting Activate Solution.
  • The Active Solution – Only one solution can be active at a time, and it is shown as a node in Solution Explorer. You can then expand the The solution's node can be expanded to reveal its contents - -- globals, forms, relations, valuelists, media, and modules. Further information about each item, when selected, will be displayed on the lower half of the Solution explorerExplorer.
  • JS Lib – The JS Lib node contains a list of preformatted scripts available for use in Servoy.
  • Plugins – This node allows access to user-installed plugins and extensions.

...

  1. The Home button – Resets the Solution Explorer view to show all the nodes available; the degree to which the trees/branches are displayed depend on the previous Home display.
  2. Back and Forward buttons – The Forward button limits the Solution Explorer list to the contents of the selected node; for example, selecting Database Servers and clicking on the Forward button displays the list of Database Servers. Selecting Back shows the previous list, in this case, the entire set of resources in Solution Explorer.
  3. Filter – is used to quickly show only items in the workspace containing the text entered in the filter.
  4. Refresh – Shows the default trees of the Solution explorer Explorer view. When the Refresh button is selected while viewing a specific node's contents, the view is reset to the list with all trees collapsed.
  5. Collapse tree – Collapses the current view to the first level nodes only.
  6. *Link with Editor* – Highlights the selected item in an active editor.

The Editor Area

Items opened from the Solution Explorer will open in an appropriate editor in the main Editor Area. For example, users can select a form to open in either a Form Editor (a graphical view of the form) or a Script Editor (a text editor). Media items will open using a supported media viewer (Servoy supports image files, and you one can assign other applications to open other file types via the Preferences menu). The following editors/viewers are provided by Servoy:

...

Most of these editors are straightforward; special features for the Form, Script , Stylesheet , Security, Database, and i18n editors are described in further detail as separate chapters or addressed in the Programming Guide.

The Properties View

The properties view shows context-specific information about a selected item in an Editor window. It is often used to assign JavaScript actions and object properties such as size and color to a form item.

...

Note

Tip: Additional Task tags can be customized and/or added via the Preferences menu, under the Javascript JavaScript node.

Activating Other Views

Other views are available via the menu item Window > Show View. Newly activated views are typically shown on the right panel (as a tab next to Properties), but users can drag the tab to any desired location in the perspective. Once a view is active, it will remain in the perspective even when Servoy is closed and reopened. The default Servoy Design Perspective perspective can be reset at any time using Window > Reset Perspective, provided the modified perspective was not saved as the default Servoy Design Perspective perspective.

Commonly used Eclipse views include the Project Explorer and Navigator. For more information, visit the Help menu.