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Using Jenkins As Continuous Build Software

This is a quote from http://jenkins-ci.org/content/about-jenkins-ci:

"In a nutshell Jenkins Cl is the leading open-source continuous integration server. Built with Java, it provides 800 plugins to support
building and testing virtually any project."
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® Other Things to Configure
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® Step 2 -- Install Separate Servoy Developer
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® Customize Jenkins Jobs to Suite Your Set of Test Solutions
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® Advanced Customization

Overview

Jenkins is a free open-source continuous build software package. It is managed by the Jenkins CI community. It is well suited for Java based projects, and
some of the more notable features include:

® Plugins for many popular builders such as Ant, Maven, ...; source control such as CVS, SVN, Git, Mercurial, ...; integration with GitHub through
various plugins; notification via email and and other means; authentication via default container authentication/OpenID/Custom users/...

¢ Other 3™ part extensions for lots of other nice features.

® Multiple jobs can be made to run at the same time, even on multiple master/slave Jenkins nodes and, using some plugins this can be configured
around a number of available external ‘resources'.

® Groovy scripts can be run directly from the web interface against a Jenkins API.

® Open source so extensible and customizable.

® Web application - the entire build/job configuration can be done via a web browser.

Installing Jenkins

Download and install Jenkins native package from http://jenkins-ci.org/. Jenkins can also be deployed as a .war file in containers such as Tomcat, but the
configuration would be identical.

For the purpose of this tutorial we will use the native Jenkins stand-alone installer.

You should now be able to access Jenkins at htt p: / /1 ocal host : 8080. This tutorial is based on a native Windows service installation, but it should be
similar on other OSes as well.

Configuration Tips

As Jenkins and Servoy are both Java driven applications, they share some Java technologies, and by default, share port configurations as well. If you plan
to run Jenkins and Servoy Application Server on the same machine, port changes will need to be made one application or the other in order for the
applications to work properly.

@ Only one or the other needs to be modified, not both.

Changing ports for a Servoy Application Server installation is detailed here.

To change port configurations for Jenkins instead, modify the j enki ns. xm file found in the Jenkins main directory. See the section below:


http://jenkins-ci.org/content/about-jenkins-ci
http://jenkins-ci.org/
https://wiki.servoy.com/display/Serv7/Network+Related+Settings
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jenkins.xml

<argunent s>- Xrs - Xnx256m - Dhudson. | i f ecycl e=hudson. | i fecycl e. WndowsSer vi ceLi fecycle -jar "%BASE% j enki ns. war "
- - htt pPort =8080</ ar gunent s>

Note that '--httpPort=8080" is in conflict with Servoy Application Server default port. Change this port to any other available port on the machine (for example
8085) then restart the Jenkins service. The new URL to access Jenkins will be htt p: / /| ocal host : 8085. (If you plan to install Jenkins as a .war inside
another container such as tomcat, then that container's configuration determines the port and the URL will be something like http://localhost:8085/jenkins)

Jenkins is fully configurable from the browser. It has many useful plugins. If you think you need something, look through the available plugins. What you
need is probably already available.

In this tutorial we will use two plugins (to install them go - in the browser - to Manage Jenkins > Manage plugins):
® openlID plugin (allows authentication based on google account (or company Google account) or any other account that provides OpenlD
authentication)
® build timeout plugin (makes sure jobs will automatically be stopped after a timeout - so your build fails if it take too long for some reason, instead of
just never ending)

Some plugins that we will use such as SVN plugin are pre-installed.

@ If you experience strange errors like '500 Internal Server Error' when configuring a Jenkins job to connect to a SVN location that requires
authentication, check for updates to the Subversion Jenkins Plugin. Before plugin version 2.0 there were problems connecting to some SVN
servers (not all) due to an old SVNK:it version used by this plugin.

At each SVN location defined in a job you will be able to choose a separate 'Credential’. Those credentials can be managed from Manage
Jenkins > Manage Credentials.

Configure Security Using openlID (skip this step if you are not interested in authentication on the
Jenkins server)

go to Manage Jenkins > Configure global security

check Enable security

choose OpenlID SSO as Security Realm and in the Provider URL field put: https://www.google.com/accounts/o8/id

choose Matrix-based security

type your google username in User/group to add and click on "Add button

grant yourself all rights by checking all checkboxes in your user's row

uncheck all checkboxes in the Anonymous row, except for Job - Discover (this one allows people to get prompted with the login when try to
access a job's URL). Please do this only after you granted yourself all rights, otherwise noone will be able to access Jenkins.

® click on Save

Now you should be the only one that can access the Jenkins server using your google credentials.

You can add any other people and configure their rights as needed now.

G) Note: Jenkins access can be configured in other ways as well, if you don't have a google/other openID account or you just want to use something
else (LDAP/custom users).

Other Things to Configure

Here are some settings you should/could tweak in Manage Jenkins > Configure System:

® if you don't have Ant installed, in Ant section add a new installation, give it a name and check Install automatically.

® download and unzip ant-contrib (for example | downloaded and unzipped ant-contrib-0.6-bin.zip) from http://sourceforge.net/projects/ant-contrib
[files/ (project page is http://ant-contrib.sourceforge.net/). Check Environment variables in Jenkins configuration page and set a key-value pair
with key '"ANT_CONTRIB_JAR' (drop the quotation marks) and value containing the full path to where the downloaded ant - contri b*. j ar is
located in the unzipped contents - including file name.

® '# of executors": set it to 1 for now; this limits the concurrent executing jobs to 1. In the future if you want to set-up a more advanced configuration
you can configure multiple jobs to run simultaneously (for example for multiple solutions) - just make sure they use separate resources so that they
don't affect each other (for example separate Servoy Installations).

* ‘Jenkins URL': to the real URL that will be used by users to access the Jenkins server. (for example this will appear as part of notification emails)

® 'System Admin e-mail address': use your email address.

® 'E-mail Notification": configure this as needed. By default it will try to use the localhost SMTP server which will already be working probably on some
linux machines. You can also test the configuration by sending a test email.

® hit the Save button.

Step-by-step Configuration for Using It with Servoy
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In the SVN repository we will have Servoy solutions that need to be automatically tested using import-smart-client and a solution to be automatically tested in
mobile-test-client. The ANT scripts used by Jenkins to automatically export and test Servoy solutions will be in a separate project 'antRunner' in the same
SVN repository.

This is what will happen when a Servoy - Jenkins job (defined later in this chapter) runs:

1. changes are fetched from SVN (solution projects, resources project(s), antRunner project);

2. root solutions are exported as .servoy files or .war mobile files. (because the .servoy workspace exporter uses the '-dbi' option in the sample ant
scripts, it will not need databases to be online, but servoy.properties must still contain the required server definitions; for the sample workspace
servoy.properties is already configured correctly);

3. test client starts a database repository - based on the repository database that must be defined in servoy.properties (if it is not defined to be an in-
memory server / HSQL, then the database must be online; for the sample workspace it will use an in-memory server, so no database needs to be
started);

4. solutions from (2) are imported into that repository (.servoy files) or in Servoy's embedded Tomcat (for mobile .war files) (databases needed by the
solutions must be online if not defined as in-memory; for the sample workspace no database server needs to be started);

5. tests run on those solutions in a test client (which is either a slightly modified smart client - to not block with modal dialogs when errors occur for
example, or a slightly modified version of mobile client);

6. results are published and emails are sent if necessary.

Step 1 -- Sample Workspace and SVN Content

Sample Workspace

First we have to set-up sample SVN contents. This can be done on any computer with access to the SVN server, not necessarily on the same computer as
Jenkins.

Here is the sample Servoy workspace that we will use: SoftwareFactory_Jenkins_Workspace.zip.
Unzip. Start Servoy Developer and switch workspace to the unzip location (File > Switch Workspace).

Go to File > Import > General > Existing Projects into Workspace. At 'Select root directory’ click the Browse button then enter (it should select the
workspace directory). Check all projects - you should see all projects that you previously unzipped. Click Finish.

You can now have a look at the sample solutions and run tests on them from developer.

Commit to Your SVN Repository

Install Subclipse plugin in Servoy Developer (Help > Install New Software) if you haven't already done so.

Open Navigator view (Window > Show view > Other > General > Navigator). Select all projects and right click > Team > Share Project > SVN.

For each project click on Share project button and add it to your SVN repository (you can use an existing SVN repository or just make a SVN test server
with SVN server software such as VisualSVN). | added it to something like htt p: / / {myHost }: { svnServer Port}/svn/j enki nsSol uti ons/trunk/
{proj ect Nane} . For the first project you will have to choose 'create repository (connection) > htt p: / / { nyHost }: { svnServer Port}/svn

/j enki nsSol ut i ons and directory 'trunk/demo_ipAddressValidator'. For the rest you will choose an existing SVN repository (the connection you just
created).

After all projects are shared, select all from Navigator view, right click > Team > Synchronize. In the Synchronize view select all and right click > Commit.

Step 2 -- Install Separate Servoy Developer

We need an installation of Servoy Developer on the machine running Jenkins for exporting test solutions and running tests.

Download and install Servoy Developer. It's best to use a clean installation (no extra eclipse plugins) to avoid potential problems generated by other eclipse
plugins (for example installing Subclipse in this developer can cause a hang as that plugin is trying to access the Ul while blocking a resource - in the
headless solution export environment).

In case of Servoy 7.x: if for some reason you intend to custom-sign any jars in that Servoy installation you must sign all the jars from both application server
(relevant here is application_server/lib/j2db.jar) and developer, as well as jars contained in developer/plugins/com.servoy.eclipse.jsunit_*.jar (relevant here is
j2db_test.jar). If these jars are not identically signed then you will get an lllegalStateException when trying to start the (smart) unit test client. But normally
you would use just a clean install without custom-signing any jars.

Step 3 -- Configure Smart Client Jenkins Job

Your Jenkins server should be able to access the SVN server you just committed to - in case you didn't use the same computer. Navigate to the Jenkins
server page in your browser.

Click on New Item > Build a free-style software project, and set the Job name to 'smart_client_tests' ('_' is used to avoid problems with spaces in paths
where used as command line arguments - extra care is needed otherwise).

Under 'Advanced Project Options' click the button then in 'Display Name' type Smart Client Tests.
Under 'Source Code Management' select Subversion. We will add the projects needed for smart client tests one by one:
1. fill Repository URL with ht t p: / / { nyHost } : { svnServer Port}/svn/j enki nsSol uti ons/trunk/sol uti onl. When you tab out of the field,

if your SVN repository requires authentication - and you didn't already provide it, you will get a red error message 'Unable to access ... ". Click on
the enter credential link and add the SVN credentials that this test server is meant to use.


https://wiki.servoy.com/download/attachments/9109675/SoftwareFactory_Jenkins_Workspace.zip?version=5&modificationDate=1394207830914&api=v2
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2. remove the dot in 'Local module directory (optional)'
3. click on Add more locations and repeat the two steps above 4 times - for the other needed projects. Use the URLs for 'solution2', 'moduleof2’,
'resources' and 'antRunner’.

Note: you can also checkout the whole branch at once if all your projects are needed for smart-client tests. Then you will have to leave the "." in ‘Local
module directory (optional)'.

Under 'Build Triggers' select 'Poll SCM' and in 'Schedule’ field use H/3 * * * * (every 3 minutes, let Jenkins choose the minute when it checks for SVN
changes to avoid overcrowding in the future). You can increase that to decrease requests on the SVN server. If changes are found Jenkins will trigger the
build. If you want a check every minute use * * * * *,

Under 'Build Environment' check 'Abort the build if it's stuck’, then select 'Absolute’ - 7 minutes. This will make sure that the build ends with failure after 7
minutes if something gets stuck. This is optional and of course you need to tweak this depending on how long your tests usually take. This option is
contributed to Jenkins by the 'build timeout plugin'.

Under 'Build’ click on Add build step. Choose Invoke Ant. Select the version you configured to auto-install at 'Other things to configure' above. Click on Adv
anced. In 'Targets' type 'main_smart'. In 'Build file' type 'antRunner/jenkins_build.xml'". In 'Properties’, expand the field (arrow down button) then type:

wor k. servoy.install.dir [ pat h_t o_your _separ at e_Servoy_devel oper _i nstal | ati on]
smart _test_sol utions = sol utionil, sol ution2

WORKSPACE ${ WORKSPACE}

ANT_CONTRI B_JAR ${ ANT_CONTRI B_JAR}

If you are on windows use '/' or '\ instead of '\ in that path. For example wor k. servoy.install.dir=f:/Servoyl nstal |l s/ Servoy_7. 3.
Under 'Post-build Actions":
® add 'Archive the artifacts' with this in 'Files to archive': ant Runner/j sunit _resul ts/junit-nofranes. htm,ant Runner/jsunit_results
/smart_inport_test_client_log.txt,antRunner/jsunit_results/workspace_exporter_app_server_| og.txt,ant Runner
/jsunit_results/workspace_exporter_workspace_| og. t xt
® add 'Publish JUnit test result report’ with 'Test report XMLs' set to: ant Runner/j sunit _resul t s/ TESTS- Test Sui t es. xm
® add 'E-mail notification' and type your email address in 'Recipients’ field.

Click on Save and go back to Jenkins dashboard. The new job you just created 'Smart Client Tests' should automatically start in under 3 minute (or you can
start it manually using the play icon next to it). It should pass.

If anything goes wrong you can click on your job's name then on the left side you see a list of builds. Click on the build that failed and you can see it's details
(time/status/tests/console/...).

| also like to have '"AUTO REFRESH' enabled as well (a link in Jenkins dashboard) - just to make sure the page is showing the latest status of Jenkins.

After a build finishes you should have 4 files in your bui |l d/ Status/Build Artifacts - one showing the test results and 3 Servoy log files showing
what happened during export/import/test.

Step 4 -- Configure Mobile Client Jenkins Job

For mobile testing we will need Chrome browser installed (other browsers, even mobile device simulations/emulations can be used, check the help page of
Servoy mobile test runner for details), a copy of SeleniumServer jar downloaded (http:/docs.seleniumhg.org/download/) and a copy of Chrome selenium
driver downloaded/extracted (http://code.google.com/p/chromedriver/downloads/list). The mobile test solution will automatically be deployed in Servoy
Developer's bundled Tomcat server (the one at [work.servoy.install.dir]) and started using Selenium in the Chrome browser to run tests - by the mobile
servoy test suite. If the tests pass, the actual mobile solution will be exported and copied to/deployed in [deploy.servoy.install.dir]'s bundled Tomcat.

Click on New Item > Build a free-style software project, and set the Job nhame to 'mobile_client_tests'.
Under 'Advanced Project Options' click the button then in 'Display Name' type ‘Mobile Client Tests'.
Under 'Source Code Management' select Subversion. We will add the projects needed for mobile client tests one by one:

1. fill Repository URL with ht t p: // { myHost } : { svnServer Port}/svn/j enki nsSol uti ons/trunk/ deno_i pAddr essVal i dat or Test er.
When you tab out of the field, if your SVN repository requires authentication - and you didn't already provide it, you will get a red error message
'Unable to access ... ". Click on the "enter credential” link and add the SVN credentials that this test server is meant to use

2. remove the dot in 'Local module directory (optional)’

3. click on 'Add more locations' and repeat the two steps above 5 times - for the other needed projects. Use the URLs for
'‘demo_ipAddressValidatorTester_service', 'demo_ipAddressValidator', '‘demo_ipAddressValidator_service', 'resources' and ‘antRunner'.

Under 'Build Triggers' select 'Poll SCM' and in 'Schedule’ field use H/3 * * * * (every 3 minutes, let Jenkins choose the minute when it checks for SVN
changes to avoid overcrowding in the future). You can increase that to decrease requests on the SVN server. If changes are found Jenkins will trigger the
build. If you want a check every minute use * * * * *,

Under 'Build Environment' check 'Abort the build if it's stuck’, then select 'Absolute’ - 10 minutes. This will make sure that the build ends with failure after 10
minutes if something gets stuck. This is optional and of course you need to tweak this depending on how long your tests usually take. This option is
contributed to Jenkins by the 'build timeout plugin'.

Under 'Build’ click on 'Add build step'. Choose 'Invoke Ant'. Select the version you configured to auto-install at 'Other things to configure' above. Click on
'Advanced'. In 'Targets' type 'main_mobile'. In 'Build file' type ‘antRunner/jenkins_build.xml". In 'Properties’, expand the field (arrow down button) then type:

If you are on windows use /' or '\\' instead of '\" in that path.
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wor k. servoy.install.dir = [path_to_your_separate_Servoy_devel oper _instal | ati on]
depl oy. servoy.install.dir = [path_to_your_depl oynment _Servoy_devel oper _i nstal | ati on]
webdriver. chrome. dri ver = [path_to_chronedriver. exe_t hat _was_downl oaded_above]
sel eni um server.jar = [pat h_t o_downl oaded_sel eni um server_j ar]
nmobi | e_t est _sol uti ons = deno_i pAddr essVal i dat or Test er
nmobi | e_servi ce_sol utions = deno_i pAddressVal i dator Tester_service
nmobi | e_t o_depl oy = deno_i pAddr essVal i dat or
nmobi | e_t o_depl oy_servi ces = deno_i pAddr essVal i dat or _service
WORKSPACE = ${ WORKSPACE}
ANT_CONTRI B_JAR = ${ ANT_CONTRI B_JAR}
For example:

wor k. servoy.install.dir = f:/Servoylnstal | s/ Servoy_7.3

depl oy. servoy.install.dir = f:/Servoylnstalls/Servoy_7.3_depl oynent

webdri ver. chrome. dri ver = f:/Sel eni um Drivers/ Chrone/ chromedriver. exe

sel eni um server.j ar = f:/Sel eni unl Server Jar/ sel eni um server - st andal one-2. 39. 0. j ar

(...)

The deployment installation of Servoy can be the one that 'Install/Start Servoy Server Importer' step will use.
Under 'Post-build Actions':

® add 'Archive the artifacts' with this in 'Files to archive': ant Runner/j sunit _resul ts/junit-nofranmes. htm,ant Runner/jsunit_results
/smart_inmport_test_client_log.txt,antRunner/jsunit_results/workspace_exporter_app_server_| og.txt,ant Runner
/jsunit_results/workspace_exporter_workspace_| og. t xt

® add 'Publish JUnit test result report’ with 'Test report XMLs' set to: ant Runner/j sunit _resul t s/ TESTS- Test Sui t es. xm

® add 'E-mail notification' and type your email address in 'Recipients’ field.

Click on Save and go back to Jenkins dashboard. The new job should automatically start in under 3 minute (or you can start it manually using the play icon
next to it). It should export/run tests in chrome/export normal solution/copy it to deployment Servoy installation - with 2 test failures. To make the tests pass
fix the regular expression as hinted by the comment in solution demo_ipAddressValidator, in the globals scope, and then commit the change to SVN.

If anything goes wrong you can click on your job's name then on the left side you see a list of builds. Click on the build that failed and you can see it's details
(time/status/tests/console/...).

After a build finishes you should have 4 files in your build/Status/Build Artifacts - one showing the test results and 3 Servoy log files showing what happened
while exporting/testing.

Customize Jenkins Jobs to Suite Your Set of Test Solutions

Congratulations! Now you should have a working sample Mobile Client test job and a working sample Smart Client test job.

Next you will probably want to configure the same for your own test solutions. Here is how you can do that.

Basic Customization

All the steps for creating jobs for your own solutions are almost identical to the sample jobs (see 'Configure Smart Client Jenkins job' and 'Configure Mobile
Client Jenkins job' above). What you should do differently:

® Under 'Source Code Management', instead of configuring sample SVN contents, configure the location of your own solutions to be checked out.
Make sure the resulting job workspace contents are similar (after checkout the job workspace directory should contain directly the solution
Iresources project directories).
® Adjust 'Abort the build if it's stuck’ value depending on how long you expect your test job to run.
® At Build > Add build step > Invoke Ant > Advanced > Properties > expanded - edit in that text-area the following properties to specifiy the
names of the root solutions relevant for your test job:
® in case of Smart Client job - replace sample tests root solution names below with your own; comma separated list:

smart _test_sol utions = sol utionl, sol uti on2

® in case of Mobile Client job - replace sample root solution names below with your own; comma separated lists:

nobi | e_t est _sol uti ons = deno_i pAddr essVal i dat or Test er

nmobi | e_service_solutions = deno_i pAddressVal i dator Tester_service
nmobi | e_t o_depl oy deno_i pAddr essVal i dat or

nobi | e_t o_depl oy_servi ces = deno_i pAddr essVal i dat or _service
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® Change the ant Runner/ servoy. properti es file as needed by your solutions (define servers and other needed changes; the repository server
can be a Hslq (in memory) server to always import clean or you can change it to a persistent server as well).

Advanced Customization

The 'Basic customization' steps should be enough for most cases. If you have the need to control more aspects like using separate servoy.properties for
exporter and import test clients, changing arguments used by exporter and import test client or modifying more timeouts that don't suit your solutions it can
be done. Here are a few more things that you can do (of course you could do much more with what Jenkins or ant have to offer):

® customize the job ant build's behavior by defining more properties in Build > Add build step > Invoke Ant > Advanced > Properties > expanded.

Customizable properties are listed in the first section of '‘antRunner/export_and_test.properties' and are explained in their comments preceding
each one:

# Properties that you should set in Jenkins job configurations (ant advanced config; they will ---
# be available to ant and al so have precedence over what is defined in this file

# Servoy devel oper installation that will be used for exporting/testing (a separate install
# is recommended for each Jenkins job in case nultiple jobs are configured to run concurrently)

wor k. servoy.install.dir = [your _j enki ns_dedi cat ed_servoy_i nstal | ati on_dir]
wor k. servoy.install.url = http://local host: 8080

# Paths to ot her downl oaded tools that we need

webdri ver. chrone. driver
sel eni um server. jar

[ pat h_t o_t he_downl oaded_sel eni um chrone_dri ver _execut abl e]
[ pat h_t o_downl oaded_sel eni um server_j ar]

# Solutions to be exported and then tested;
# mul tiple solutions can be specified via a comm separated |ist of solution nanes

smart _test_sol utions = sol utionl, sol ution2

nmobi | e_t est _sol uti ons = deno_i pAddr essVal i dat or Test er
nmobi | e_servi ce_sol utions deno_i pAddr essVal i dat or Test er _servi ce

nmobi | e_t o_depl oy
nmobi | e_t o_depl oy_servi ces

deno_i pAddr essVal i dat or
deno_i pAddr essVal i dat or _servi ce

# If you are using a Servoy version >= 7.3 please uncomment or set the followi ng (otherw se |eave it
# comrented out; setting it to "false" or "nope" is not the sane); the old way should work on 7.3 or
# newer as well, but not the other way around; new way only only gets rid of sonme unneeded exporter
# initialization time

# work. servoy.install.7.3.or.higher = yep

# 1 hour tine-out; edit this as needed - depending on how long it usually takes for your solution tests to
run (shoul d probably be |ower in npbst cases)

test.tinmeout = 3600000
# Uncomment the following to send '-pl*'
| ocati ons;

# solution and resources projects will be searched for in direct subfolders of the given ' WORKSPACE' .

# Exanmple: if the workspace needs to contain projects fromdifferent git repositories, those can be checked
# out in '[ WORKSPACE]/repol', '[WORKSPACE]/repo2' and so on

argunent to workspace sol ution exporters: alternate project

#al ternat e_proj ect _| ocati ons. on=yep

# Uncomment the following line/set this if you want passed exports generated by previous build
# to be deleted at the beginning of each build cycle

#al ways_cl ean_passed_exports = yep

# For Sauce Labs test cloud (testing nobile clients); also uncoment relevant lines in
# "run_nobile_client_tests_if_exported_ok" target of jenkins_build.xm; other changes might be needed as

well, but this is the main idea

#sauce. | abs. user = [your Sauce Labs user here]

#sauce. | abs. t oken = [access token goes here]

#sauce. | abs. sel eni um url = http://${sauce. | abs. user}: ${sauce. | abs. t oken}

@ ocal host : ${ SAUCE_ ONDEMAND_PORT} / wd/ hub
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# define a tinmeout for sauce |labs to not require additional Seleniumcomands for a solution (set to 1.5
m n; should be updated for how | ong your test can possibly take to run, but not much higher)
#sauce. | abs. sel eni um i dl e-ti meout =90

# If you want your nobile solutions deployed to a Servoy server after testing is done,

# uncomment / set values as in the following two |ines and change the val ue of

# servoy.deploy.install.dir to point to it; passed .war files will be copied to depl oy. webapps. dir
| ocati on.

#depl oy. servoy.install.dir = [your _nobi |l e_war _depl oyment _servoy_i nstal |l ati on]
#depl oy. webapps. di r ${depl oy. servoy.install.dir}/application_server/server/webapps

# WORKSPACE property is nornmally already set by Jenkins in job build step

# ANT_CONTRIB_JAR is nornally already set if you followed all the steps in "Building a Software Factory"
W KI

# page; it's set as a system property in global Jenkins configuration - environment variabl es

#WORKSPACE
#ANT_CONTRI B_JAR =
[if_not_set _in_Jenkins_config_as_environnment_variable_you_can_configure_it_as_well]

[if_not_set_by Jenkins_you_can_configure_it_as_well]

® workspace exporter arguments (you should have available all the options present in Ul Solution Export Wizard) can be customized by modifying an
t Runner/ export _and_t est. xm macrodefs 'export-solution' and 'export-mobile-solution’. You can see a list of available command line
arguments in a console window by executing { ser voyl nst al | }/ devel oper/exporter/export.bat -helpand{servoylnstall}
/ devel oper/ exporter/ mobil e_export.bat -help;

® smart test client and mobile test client arguments (which are actually system properties sent to a junit test suite) can be customized by modifying an
t Runner/ export _and_t est. xm macrodefs 'run-smart-client-tests' and 'run-mobile-client-tests'. You can see a list of available arguments by
commenting out the '<! - -ar g val ue="-hel p" /-->'lines in these marcrodefs and creating/executing an ant task that calls them from the
command line (or alternatively just comment out those lines in a Jenkins job and check the job build's console - after it is executed).
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